re = /^(?!$)\s+|\s+(?<!^)$|(?<=\?).*|(.)\1*(?=\1{2})|[^-\w\s.?]|\b(?<!['-])((?:['\w-])+)\b(?=\W+\2)\s*/im
str = ' Well well well well, let\'s seeeeee what what the the ===^&the %$#@!the the 500006 edition boook has has## to #say #$%^&- <_______about___> this_thing? None of your business!
spaces removed '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result