# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!$)\s+|\s+(?<!^)$|(?<=\?).*|(.)\1*(?=\1{2})|[^-\w\s.?]|\b(?<!['-])((?:['\w-])+)\b(?=\W+\2)\s*"
test_str = (" Well well well well, let's seeeeee what what the the ===^&the %$#@!the the 500006 edition boook has has## to #say #$%^&- <_______about___> this_thing? None of your business!\n\n"
" spaces removed ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.