const regex = new RegExp('((?:\\+\\d{2}[-.\\s]?(?:\\(0\\)|0)*?[-.\\s]?|00[-.\\s]?\\d{2}[-.\\s]?(?:\\(0\\)|0)*?[-.\\s]?|0)\\d?[-.\\s]?(?:\\d{2}[-.\\s]?){3,4})(?:$|\\D)', 'gm')
const str = `06 10 20 30 40
0710203040
06-10-20-30-40
+33 6 10 20 30 40
+33610203040
+33-7-10-20-30-40
+44123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}