re = /((?:\+\d{2}[-.\s]?(?:\(0\)|0)*?[-.\s]?|00[-.\s]?\d{2}[-.\s]?(?:\(0\)|0)*?[-.\s]?|0)\d?[-.\s]?(?:\d{2}[-.\s]?){3,4})(?:$|\D)/m
str = '06 10 20 30 40
0710203040
06-10-20-30-40
+33 6 10 20 30 40
+33610203040
+33-7-10-20-30-40
+44123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end