import re
regex = re.compile(r"((?:\+\d{2}[-.\s]?(?:\(0\)|0)*?[-.\s]?|00[-.\s]?\d{2}[-.\s]?(?:\(0\)|0)*?[-.\s]?|0)\d?[-.\s]?(?:\d{2}[-.\s]?){3,4})(?:$|\D)", flags=re.MULTILINE)
test_str = ("06 10 20 30 40\n"
"0710203040\n"
"06-10-20-30-40\n"
"+33 6 10 20 30 40\n"
"+33610203040\n"
"+33-7-10-20-30-40\n"
"+44123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")