$re = '/{{(.*?)}}/';
$str = '{{ url(\'mr_message_read\', {id: message.id}) }}
{{ object.property }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);