re = /{{(.*?)}}/
str = '{{ url(\'mr_message_read\', {id: message.id}) }}
{{ object.property }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end