#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(\d)(?!\d*\g{-1}))+$"
Local $sString = "12" & @CRLF & _
"34" & @CRLF & _
"44" & @CRLF & _
"55" & @CRLF & _
"65" & @CRLF & _
"654" & @CRLF & _
"6554" & @CRLF & _
"76543" & @CRLF & _
"765433"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")