import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\d)(?!\\d*\\g\\{-1\\}))+$";
final String string = "12\n"
+ "34\n"
+ "44\n"
+ "55\n"
+ "65\n"
+ "654\n"
+ "6554\n"
+ "76543\n"
+ "765433";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}