#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([3-9]\d|[1-9]\d{2,})"
Local $sString = "0 then Ruzzlzz decided to bow down 30 times to FairySubsTeam" & @CRLF & _
"using regex where 10 is not captured, while 59 is captured" & @CRLF & _
"this is a sample of "<INEQUALITY>||<30"" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"29" & @CRLF & _
"30" & @CRLF & _
"49" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"1000000000000" & @CRLF & _
"999999999999999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")