import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([3-9]\\d|[1-9]\\d{2,})";
final String string = "0 then Ruzzlzz decided to bow down 30 times to FairySubsTeam\n"
+ "using regex where 10 is not captured, while 59 is captured\n"
+ "this is a sample of \"<INEQUALITY>||<30\"\n"
+ "1\n"
+ "10\n"
+ "29\n"
+ "30\n"
+ "49\n"
+ "99\n"
+ "100\n"
+ "1000000000000\n"
+ "999999999999999999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}