const regex = /(?<!GAS )TOTAL\s*(\$\d+\.\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!GAS )TOTAL\\s*(\\$\\d+\\.\\d+)', 'g')
const str = `SPEEDWAY 3007906
Wallace NC 28466
TRAM: 1086244
9/17/2017 2:12 pm
Pump 08
Regular Unleaded
8,716 @ \$2,639/6131
GAS TOTAL \$23.00
TAX \$0.03
TOTAL \$23.80
Uisa `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}