# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!GAS )TOTAL\s*(\$\d+\.\d+)"
test_str = ("SPEEDWAY 3007906 \n"
"Wallace NC 28466 \n"
"TRAM: 1086244 \n"
"9/17/2017 2:12 pm \n"
"Pump 08 \n"
"Regular Unleaded \n"
"8,716 @ $2,639/6131 \n"
"GAS TOTAL $23.00\n"
"TAX $0.03 \n"
"TOTAL $23.80\n"
"Uisa ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.