import re
regex = re.compile(r"(?m)(?<=^(\s*)(?:[^\s:][^:\r\n]*)?: \|\s*)(?:\r?\n(?!\1\S).*)+", flags=re.MULTILINE)
test_str = ("kind: ConfigMap\n"
"apiVersion: v1\n"
"metadata:\n"
" name: {{ .Release.Name }}-nginx-index-html-configmap\n"
"data:\n"
" startRegexMatch.html: |\n"
" <!DOCTYPE html>\n"
" <html>\n"
" <head>\n"
" <title>Up & Running!</title>\n"
" <style>\n"
" body {\n"
" width: 60em;\n"
" margin: 0 auto;\n"
" font-family: Tahoma, Verdana, Arial, sans-serif;\n"
" }\n"
" </style>\n"
" </head>\n"
" <body>\n"
" <h1>Up & Running!</h1>\n\n"
" <pre style=\"float:left;\">\n"
" 888 888 888 d88P 888 8888888P\" 8888888P\" 888 888 888d88888b888 888 888 8888888P\" 8888888b \"Y88b. 888\n"
" 8888888888 88888888 \"Y8888P\" d88P 888 888 T88b 888 T88b \"Y88888P\" 888P Y888 \"Y88888P\" 888 T88b 888 Y88b \"Y8888P\" 888 </pre>\n"
" </body>\n"
" </html>\n"
" stopRegexMatch:")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")