import Foundation
let pattern = #"(?m)(?<=^(\s*)(?:[^\s:][^:\r\n]*)?: \|\s*)(?:\r?\n(?!\1\S).*)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
kind: ConfigMap
apiVersion: v1
metadata:
name: {{ .Release.Name }}-nginx-index-html-configmap
data:
startRegexMatch.html: |
<!DOCTYPE html>
<html>
<head>
<title>Up & Running!</title>
<style>
body {
width: 60em;
margin: 0 auto;
font-family: Tahoma, Verdana, Arial, sans-serif;
}
</style>
</head>
<body>
<h1>Up & Running!</h1>
<pre style="float:left;">
888 888 888 d88P 888 8888888P" 8888888P" 888 888 888d88888b888 888 888 8888888P" 8888888b "Y88b. 888
8888888888 88888888 "Y8888P" d88P 888 888 T88b 888 T88b "Y88888P" 888P Y888 "Y88888P" 888 T88b 888 Y88b "Y8888P" 888 </pre>
</body>
</html>
stopRegexMatch:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)