import re
regex = re.compile(r"(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6})(\.[a-z0-9]{2,6})?\/?(.*)$", flags=re.MULTILINE)
test_str = ("https://stackoverflow.com/questions/ask\n"
"https://stackoverflow.co.uk/questions/ask\n"
"https://www.stackoverflow.com/questions/ask\n"
"http://www.stackoverflow.co.uk/questions/ask\n"
"http://www.stackoverflow.co.uk/\n"
"http://www.stackoverflow.co.uk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")