package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)"`)
var str = `{"searchRecords":[{"attributes":{"type":"Lead","url":"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD"},"Id":"00Q1300001TDlooEAD","Lead_Owner_Email__c":"mgq23@drexel.edu","InquiryProgram__r":{"attributes":{"type":"Program__c","url":"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF"},"School__c":"NH","Level__c":"Graduate"}}]}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}