import Foundation
let pattern = #""Lead_Owner_Email__c":"(?<leadOwner>.*?)".*?"School__c":"(?<school>.*?)".*?"Level__c":"(?<level>.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"searchRecords":[{"attributes":{"type":"Lead","url":"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD"},"Id":"00Q1300001TDlooEAD","Lead_Owner_Email__c":"mgq23@drexel.edu","InquiryProgram__r":{"attributes":{"type":"Program__c","url":"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF"},"School__c":"NH","Level__c":"Graduate"}}]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)