import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Lead_Owner_Email__c\":\"(?<leadOwner>.*?)\".*?\"School__c\":\"(?<school>.*?)\".*?\"Level__c\":\"(?<level>.*?)\"";
final String string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Lead\",\"url\":\"/services/data/v43.0/sobjects/Lead/00Q1300001TDlooEAD\"},\"Id\":\"00Q1300001TDlooEAD\",\"Lead_Owner_Email__c\":\"mgq23@drexel.edu\",\"InquiryProgram__r\":{\"attributes\":{\"type\":\"Program__c\",\"url\":\"/services/data/v43.0/sobjects/Program__c/a03a000000FcFl1AAF\"},\"School__c\":\"NH\",\"Level__c\":\"Graduate\"}}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}