using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/my\/service\/url\?.*(specificParam.*(M[0-9]{9})).*$";
string input = @"/my/service/url?saml2=disabled&filter=specificParam%20eq%20%27M012345678%27";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}