$re = '/^\/my\/service\/url\?.*(specificParam.*(M[0-9]{9})).*$/m';
$str = '/my/service/url?saml2=disabled&filter=specificParam%20eq%20%27M012345678%27';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);