package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/my\/service\/url\?.*(specificParam.*(M[0-9]{9})).*$`)
var str = `/my/service/url?saml2=disabled&filter=specificParam%20eq%20%27M012345678%27`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}