import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\t\\p{Zs}]*\\([\\pZs\\}\\t](?:[^()\\n]*[\\pZs\\}\\t])?\\)[\\pZs\\}\\t]*$";
final String string = " ( )\n"
+ " ( This is a comment )\n"
+ " 1 2 +\n"
+ "\\ a\n"
+ ": square dup * ;\n"
+ "( foo bar \n"
+ "baz )\n"
+ "(quux)\n"
+ "( ( )\n"
+ "(\n"
+ "( )";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}