re = /^[\t\p{Zs}]*\([\pZs}\t](?:[^()\n]*[\pZs}\t])?\)[\pZs}\t]*$/m
str = ' ( )
( This is a comment )
1 2 +
\\ a
: square dup * ;
( foo bar
baz )
(quux)
( ( )
(
( )'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end