$re = '`^[\t\p{Zs}]*\([\pZs}\t](?:[^()\n]*[\pZs}\t])?\)[\pZs}\t]*$`m';
$str = ' ( )
( This is a comment )
1 2 +
\\ a
: square dup * ;
( foo bar
baz )
(quux)
( ( )
(
( )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);