package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(blog|hub)\.rangeforce\.com`)
var str = `matches: blog.rangeforce.com
matches: hub.rangeforce.com
doesn't match: somethingelse.rangeforce.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}