re = /(blog|hub)\.rangeforce\.com/m
str = 'matches: blog.rangeforce.com
matches: hub.rangeforce.com
doesn\'t match: somethingelse.rangeforce.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end