$re = '/(blog|hub)\.rangeforce\.com/m';
$str = 'matches: blog.rangeforce.com
matches: hub.rangeforce.com
doesn\'t match: somethingelse.rangeforce.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);