#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((http|ftp|https):\/\/)?(([\w.-]*)\.([\w]*))"
Local $sString = "Hello www.google.com World http://yahoo.com" & @CRLF & _
"" & @CRLF & _
"https://www.google.com.tr/admin/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"https://google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"http://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"ftp://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"www.google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"www.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
"drive.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")