import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((http|ftp|https):\\/\\/)?(([\\w.-]*)\\.([\\w]*))";
final String string = "Hello www.google.com World http://yahoo.com\n\n"
+ "https://www.google.com.tr/admin/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "https://google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "http://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "ftp://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "www.google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "www.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
+ "drive.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}