# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((http|ftp|https):\/\/)?(([\w.-]*)\.([\w]*))"
test_str = ("Hello www.google.com World http://yahoo.com\n\n"
"https://www.google.com.tr/admin/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"https://google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"http://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"ftp://google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"www.google.com.tr/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"www.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n"
"drive.google.com/test/subPage?qs1=sss1&qs2=sss2&qs3=sss3#Services\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.