#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?!NT\s*LANMAN\s*)LANMAN"
Local $sString = "PC NETWORK PROGRAM 1.0 \" & @CRLF & _
"NT LM 0.12 \" & @CRLF & _
"NT LANMAN \" & @CRLF & _
"SMB 2.002 \" & @CRLF & _
"SMB 2.??? \" & @CRLF & _
"LANMAN"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")