re = /(?!NT\s*LANMAN\s*)LANMAN/
str = 'PC NETWORK PROGRAM 1.0 \\
NT LM 0.12 \\
NT LANMAN \\
SMB 2.002 \\
SMB 2.??? \\
LANMAN'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end