$re = '/(?!NT\s*LANMAN\s*)LANMAN/';
$str = 'PC NETWORK PROGRAM 1.0 \\
NT LM 0.12 \\
NT LANMAN \\
SMB 2.002 \\
SMB 2.??? \\
LANMAN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);