import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+\\d{2} )\\d{3}\\.?\\d{3}\\.?\\d{3}|\\d{4}([ .]?)\\d{3}\\1\\d{3}";
final String string = "+84 934.567.678 \n"
+ "+84 934567678 \n"
+ "0934 567 678 \n"
+ "0934.567.678";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}