re = /(?:\+\d{2} )\d{3}\.?\d{3}\.?\d{3}|\d{4}([ .]?)\d{3}\1\d{3}/m
str = '+84 934.567.678
+84 934567678
0934 567 678
0934.567.678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end