$re = '/(?:\+\d{2} )\d{3}\.?\d{3}\.?\d{3}|\d{4}([ .]?)\d{3}\1\d{3}/m';
$str = '+84 934.567.678
+84 934567678
0934 567 678
0934.567.678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);