#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(1558)[\d{6}]|^(310)[\d{9}]"
Local $sString = "1558218374" & @CRLF & _
"1559218374" & @CRLF & _
"1234567899" & @CRLF & _
"2155817896" & @CRLF & _
"310123456789" & @CRLF & _
"311123456789" & @CRLF & _
"131023456789" & @CRLF & _
"123456789999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")