using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(1558)[\d{6}]|^(310)[\d{9}]";
string input = @"1558218374
1559218374
1234567899
2155817896
310123456789
311123456789
131023456789
123456789999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}