import re
regex = re.compile(r"^(1558)[\d{6}]|^(310)[\d{9}]", flags=re.MULTILINE)
test_str = ("1558218374\n"
"1559218374\n"
"1234567899\n"
"2155817896\n"
"310123456789\n"
"311123456789\n"
"131023456789\n"
"123456789999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")