package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(b[aä]e?ck(er)?\S*)`)
var str = `bäcker
baecker
baeckerei
backshop
bAckshop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}