$re = '/(?i)(b[aä]e?ck(er)?\S*)/m';
$str = 'bäcker
baecker
baeckerei
backshop
bAckshop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);