re = /(?i)(b[aä]e?ck(er)?\S*)/m
str = 'bäcker
baecker
baeckerei
backshop
bAckshop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end