const regex = /_\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_\\d+$', 'gm')
const str = `lorem_ipsum_test1_123
lorem_ipsum_test2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);