use strict;
my $str = 'lorem_ipsum_test1_123
lorem_ipsum_test2';
my $regex = qr/_\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";