re = /_\d+$/m
str = 'lorem_ipsum_test1_123
lorem_ipsum_test2'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result