import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[!(?P<command>\\w+)(?:!(?P<subcommand>\\w+))? *(?P<settings>\\w+=.*?)?\\](?:\\((?P<inline>.*?)\\))";
final String string = "### The I_Soil System\n\n"
+ "The I-soil material model is a nonlinear hysteretic soil model that is based on the distributed\n"
+ "element models developed by [!citet](iwan1967on) and [!citet](chiang1994anew). In 1-D, this model takes\n"
+ "the backbone stress-strain curve and divides it into a set of elastic-perfectly plastic curves. The\n"
+ "total stress then is the sum of the stresses from the individual elastic-perfectly plastic curves.\n\n"
+ "The three dimensional generalization of this model is achieved using von-Mises failure criteria for\n"
+ "each elastic-perfectly plastic curve resulting in an invariant yield surfaces in three-dimensional\n"
+ "stress space like in [fig:yieldsurface] (after [!citet](chiang1994anew)).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}