const regex = new RegExp('\\[!(?P<command>\\w+)(?:!(?P<subcommand>\\w+))? *(?P<settings>\\w+=.*?)?\\](?:\\((?P<inline>.*?)\\))', 'gm')
const str = `### The I_Soil System
The I-soil material model is a nonlinear hysteretic soil model that is based on the distributed
element models developed by [!citet](iwan1967on) and [!citet](chiang1994anew). In 1-D, this model takes
the backbone stress-strain curve and divides it into a set of elastic-perfectly plastic curves. The
total stress then is the sum of the stresses from the individual elastic-perfectly plastic curves.
The three dimensional generalization of this model is achieved using von-Mises failure criteria for
each elastic-perfectly plastic curve resulting in an invariant yield surfaces in three-dimensional
stress space like in [fig:yieldsurface] (after [!citet](chiang1994anew)).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}