import Foundation
let pattern = #"\[!(?P<command>\w+)(?:!(?P<subcommand>\w+))? *(?P<settings>\w+=.*?)?\](?:\((?P<inline>.*?)\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ####"""
### The I_Soil System
The I-soil material model is a nonlinear hysteretic soil model that is based on the distributed
element models developed by [!citet](iwan1967on) and [!citet](chiang1994anew). In 1-D, this model takes
the backbone stress-strain curve and divides it into a set of elastic-perfectly plastic curves. The
total stress then is the sum of the stresses from the individual elastic-perfectly plastic curves.
The three dimensional generalization of this model is achieved using von-Mises failure criteria for
each elastic-perfectly plastic curve resulting in an invariant yield surfaces in three-dimensional
stress space like in [fig:yieldsurface] (after [!citet](chiang1994anew)).
"""####
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)