$re = '/\/\*[\s\S]*?\*\/|([^\\\\:]|^)\/\/.*$/m';
$str = '// comments at the beginning of the file are removed
********************************************************
Please take note of the items highlighted in green//.
These are held in back reference "$1" which you MUST
use in your replacement value or else your program will
break.//
********************************************************
/*
Block comments are removed - easy peasy
*/
https://urls.are.preserved.for.you// and comments after them are removed
asdfasdf// the comment can bump right up to text
asdfasdf;// ...or a semicolon.
{
foo:// you will need a parser to remove this comment b/c it smells like a URL
"bar",// ...but not this one
boo: // ...or this one
"who"
}
x.replace(/\\//g, \'/\');
}//';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);